[DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

[DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

Yuriy Babak
Hi Igniters,

What do you think about the drop Scala 2.10 support?

Currently, we support two versions of Scala - 2.10 and 2.11, I suggest to
drop 2.10 and use only 2.11. Originally we have the old version of Scala
for supporting old versions of Apache Spark.

But support for Scala 2.10 was removed as of 2.3.0 Apache Spark released.
And current version if 2.4.0.

Please share your opinion

Best regards,
Yuriy Babak
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

Alexey Kuznetsov
+1 to drop support of Scala 2.10 in Ignite 2.8.


On Thu, Jan 10, 2019 at 9:59 PM Yuriy Babak <[hidden email]> wrote:

> Hi Igniters,
>
> What do you think about the drop Scala 2.10 support?
>
> Currently, we support two versions of Scala - 2.10 and 2.11, I suggest to
> drop 2.10 and use only 2.11. Originally we have the old version of Scala
> for supporting old versions of Apache Spark.
>
> But support for Scala 2.10 was removed as of 2.3.0 Apache Spark released.
> And current version if 2.4.0.
>
> Please share your opinion
>
> Best regards,
> Yuriy Babak
>


--
Alexey Kuznetsov
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

Anton Vinogradov-2
+1

On Thu, Jan 10, 2019 at 6:02 PM Alexey Kuznetsov <[hidden email]>
wrote:

> +1 to drop support of Scala 2.10 in Ignite 2.8.
>
>
> On Thu, Jan 10, 2019 at 9:59 PM Yuriy Babak <[hidden email]> wrote:
>
> > Hi Igniters,
> >
> > What do you think about the drop Scala 2.10 support?
> >
> > Currently, we support two versions of Scala - 2.10 and 2.11, I suggest to
> > drop 2.10 and use only 2.11. Originally we have the old version of Scala
> > for supporting old versions of Apache Spark.
> >
> > But support for Scala 2.10 was removed as of 2.3.0 Apache Spark released.
> > And current version if 2.4.0.
> >
> > Please share your opinion
> >
> > Best regards,
> > Yuriy Babak
> >
>
>
> --
> Alexey Kuznetsov
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

Nikolay Izhikov-2
+1

чт, 10 янв. 2019 г. в 19:09, Anton Vinogradov <[hidden email]>:

> +1
>
> On Thu, Jan 10, 2019 at 6:02 PM Alexey Kuznetsov <[hidden email]>
> wrote:
>
> > +1 to drop support of Scala 2.10 in Ignite 2.8.
> >
> >
> > On Thu, Jan 10, 2019 at 9:59 PM Yuriy Babak <[hidden email]> wrote:
> >
> > > Hi Igniters,
> > >
> > > What do you think about the drop Scala 2.10 support?
> > >
> > > Currently, we support two versions of Scala - 2.10 and 2.11, I suggest
> to
> > > drop 2.10 and use only 2.11. Originally we have the old version of
> Scala
> > > for supporting old versions of Apache Spark.
> > >
> > > But support for Scala 2.10 was removed as of 2.3.0 Apache Spark
> released.
> > > And current version if 2.4.0.
> > >
> > > Please share your opinion
> > >
> > > Best regards,
> > > Yuriy Babak
> > >
> >
> >
> > --
> > Alexey Kuznetsov
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

Denis Magda-2
I see that we're getting around 150 scala_2.10 downloads monthly. Is there
any other component which uses it? I would remove the module in 3.0 to not
break the compatibility.

--
Denis

On Thu, Jan 10, 2019 at 8:13 AM Nikolay Izhikov <[hidden email]> wrote:

> +1
>
> чт, 10 янв. 2019 г. в 19:09, Anton Vinogradov <[hidden email]>:
>
> > +1
> >
> > On Thu, Jan 10, 2019 at 6:02 PM Alexey Kuznetsov <[hidden email]>
> > wrote:
> >
> > > +1 to drop support of Scala 2.10 in Ignite 2.8.
> > >
> > >
> > > On Thu, Jan 10, 2019 at 9:59 PM Yuriy Babak <[hidden email]> wrote:
> > >
> > > > Hi Igniters,
> > > >
> > > > What do you think about the drop Scala 2.10 support?
> > > >
> > > > Currently, we support two versions of Scala - 2.10 and 2.11, I
> suggest
> > to
> > > > drop 2.10 and use only 2.11. Originally we have the old version of
> > Scala
> > > > for supporting old versions of Apache Spark.
> > > >
> > > > But support for Scala 2.10 was removed as of 2.3.0 Apache Spark
> > released.
> > > > And current version if 2.4.0.
> > > >
> > > > Please share your opinion
> > > >
> > > > Best regards,
> > > > Yuriy Babak
> > > >
> > >
> > >
> > > --
> > > Alexey Kuznetsov
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

Anton Vinogradov-2
Denis,

Could you please specify what component and what type of downloads do you
mean.
What is the ratio between 2.10 and actual?

P.s. There is a big chance that 150 downloads caused by TC or by Release
check.

On Fri, Jan 11, 2019 at 2:17 AM Denis Magda <[hidden email]> wrote:

> I see that we're getting around 150 scala_2.10 downloads monthly. Is there
> any other component which uses it? I would remove the module in 3.0 to not
> break the compatibility.
>
> --
> Denis
>
> On Thu, Jan 10, 2019 at 8:13 AM Nikolay Izhikov <[hidden email]>
> wrote:
>
> > +1
> >
> > чт, 10 янв. 2019 г. в 19:09, Anton Vinogradov <[hidden email]>:
> >
> > > +1
> > >
> > > On Thu, Jan 10, 2019 at 6:02 PM Alexey Kuznetsov <
> [hidden email]>
> > > wrote:
> > >
> > > > +1 to drop support of Scala 2.10 in Ignite 2.8.
> > > >
> > > >
> > > > On Thu, Jan 10, 2019 at 9:59 PM Yuriy Babak <[hidden email]>
> wrote:
> > > >
> > > > > Hi Igniters,
> > > > >
> > > > > What do you think about the drop Scala 2.10 support?
> > > > >
> > > > > Currently, we support two versions of Scala - 2.10 and 2.11, I
> > suggest
> > > to
> > > > > drop 2.10 and use only 2.11. Originally we have the old version of
> > > Scala
> > > > > for supporting old versions of Apache Spark.
> > > > >
> > > > > But support for Scala 2.10 was removed as of 2.3.0 Apache Spark
> > > released.
> > > > > And current version if 2.4.0.
> > > > >
> > > > > Please share your opinion
> > > > >
> > > > > Best regards,
> > > > > Yuriy Babak
> > > > >
> > > >
> > > >
> > > > --
> > > > Alexey Kuznetsov
> > > >
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

Alexey Zinoviev
Also, for future releases Ignite-Spark connection we could start with
testing of scala 2.12 profile because Spark 2.4 could be run on Scala 2.12
See the link https://issues.apache.org/jira/browse/SPARK-14220

I also support drop 2.10 profile but later, in 3.0 release to wait more
widely adoption of Scala 2.12 (I know a few projects who waited new version
Spark to upgrade codebase from Scala 2.10 to 2.12)


пт, 11 янв. 2019 г. в 11:59, Anton Vinogradov <[hidden email]>:

> Denis,
>
> Could you please specify what component and what type of downloads do you
> mean.
> What is the ratio between 2.10 and actual?
>
> P.s. There is a big chance that 150 downloads caused by TC or by Release
> check.
>
> On Fri, Jan 11, 2019 at 2:17 AM Denis Magda <[hidden email]> wrote:
>
> > I see that we're getting around 150 scala_2.10 downloads monthly. Is
> there
> > any other component which uses it? I would remove the module in 3.0 to
> not
> > break the compatibility.
> >
> > --
> > Denis
> >
> > On Thu, Jan 10, 2019 at 8:13 AM Nikolay Izhikov <[hidden email]>
> > wrote:
> >
> > > +1
> > >
> > > чт, 10 янв. 2019 г. в 19:09, Anton Vinogradov <[hidden email]>:
> > >
> > > > +1
> > > >
> > > > On Thu, Jan 10, 2019 at 6:02 PM Alexey Kuznetsov <
> > [hidden email]>
> > > > wrote:
> > > >
> > > > > +1 to drop support of Scala 2.10 in Ignite 2.8.
> > > > >
> > > > >
> > > > > On Thu, Jan 10, 2019 at 9:59 PM Yuriy Babak <[hidden email]>
> > wrote:
> > > > >
> > > > > > Hi Igniters,
> > > > > >
> > > > > > What do you think about the drop Scala 2.10 support?
> > > > > >
> > > > > > Currently, we support two versions of Scala - 2.10 and 2.11, I
> > > suggest
> > > > to
> > > > > > drop 2.10 and use only 2.11. Originally we have the old version
> of
> > > > Scala
> > > > > > for supporting old versions of Apache Spark.
> > > > > >
> > > > > > But support for Scala 2.10 was removed as of 2.3.0 Apache Spark
> > > > released.
> > > > > > And current version if 2.4.0.
> > > > > >
> > > > > > Please share your opinion
> > > > > >
> > > > > > Best regards,
> > > > > > Yuriy Babak
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Alexey Kuznetsov
> > > > >
> > > >
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

Denis Magda-2
In reply to this post by Anton Vinogradov-2
1500 (2.11) vs 150 (2.10) - downloads of ignite-scalar artifacts of defined
version. My point is that those few who are on 2.10 should be considered -
we usually don't do breaking changes in minor releases, only major.

Ignite 3.0?

--
Denis

On Fri, Jan 11, 2019 at 12:59 AM Anton Vinogradov <[hidden email]> wrote:

> Denis,
>
> Could you please specify what component and what type of downloads do you
> mean.
> What is the ratio between 2.10 and actual?
>
> P.s. There is a big chance that 150 downloads caused by TC or by Release
> check.
>
> On Fri, Jan 11, 2019 at 2:17 AM Denis Magda <[hidden email]> wrote:
>
> > I see that we're getting around 150 scala_2.10 downloads monthly. Is
> there
> > any other component which uses it? I would remove the module in 3.0 to
> not
> > break the compatibility.
> >
> > --
> > Denis
> >
> > On Thu, Jan 10, 2019 at 8:13 AM Nikolay Izhikov <[hidden email]>
> > wrote:
> >
> > > +1
> > >
> > > чт, 10 янв. 2019 г. в 19:09, Anton Vinogradov <[hidden email]>:
> > >
> > > > +1
> > > >
> > > > On Thu, Jan 10, 2019 at 6:02 PM Alexey Kuznetsov <
> > [hidden email]>
> > > > wrote:
> > > >
> > > > > +1 to drop support of Scala 2.10 in Ignite 2.8.
> > > > >
> > > > >
> > > > > On Thu, Jan 10, 2019 at 9:59 PM Yuriy Babak <[hidden email]>
> > wrote:
> > > > >
> > > > > > Hi Igniters,
> > > > > >
> > > > > > What do you think about the drop Scala 2.10 support?
> > > > > >
> > > > > > Currently, we support two versions of Scala - 2.10 and 2.11, I
> > > suggest
> > > > to
> > > > > > drop 2.10 and use only 2.11. Originally we have the old version
> of
> > > > Scala
> > > > > > for supporting old versions of Apache Spark.
> > > > > >
> > > > > > But support for Scala 2.10 was removed as of 2.3.0 Apache Spark
> > > > released.
> > > > > > And current version if 2.4.0.
> > > > > >
> > > > > > Please share your opinion
> > > > > >
> > > > > > Best regards,
> > > > > > Yuriy Babak
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Alexey Kuznetsov
> > > > >
> > > >
> > >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSSION] Drop Scala 2.10 for Apache Ignite 2.8

Yuriy Babak
In that case my vote for 3.0 release

Best regards,
Yuriy Babak


пт, 11 янв. 2019 г. в 21:29, Denis Magda <[hidden email]>:

> 1500 (2.11) vs 150 (2.10) - downloads of ignite-scalar artifacts of defined
> version. My point is that those few who are on 2.10 should be considered -
> we usually don't do breaking changes in minor releases, only major.
>
> Ignite 3.0?
>
> --
> Denis
>
> On Fri, Jan 11, 2019 at 12:59 AM Anton Vinogradov <[hidden email]> wrote:
>
> > Denis,
> >
> > Could you please specify what component and what type of downloads do you
> > mean.
> > What is the ratio between 2.10 and actual?
> >
> > P.s. There is a big chance that 150 downloads caused by TC or by Release
> > check.
> >
> > On Fri, Jan 11, 2019 at 2:17 AM Denis Magda <[hidden email]> wrote:
> >
> > > I see that we're getting around 150 scala_2.10 downloads monthly. Is
> > there
> > > any other component which uses it? I would remove the module in 3.0 to
> > not
> > > break the compatibility.
> > >
> > > --
> > > Denis
> > >
> > > On Thu, Jan 10, 2019 at 8:13 AM Nikolay Izhikov <[hidden email]>
> > > wrote:
> > >
> > > > +1
> > > >
> > > > чт, 10 янв. 2019 г. в 19:09, Anton Vinogradov <[hidden email]>:
> > > >
> > > > > +1
> > > > >
> > > > > On Thu, Jan 10, 2019 at 6:02 PM Alexey Kuznetsov <
> > > [hidden email]>
> > > > > wrote:
> > > > >
> > > > > > +1 to drop support of Scala 2.10 in Ignite 2.8.
> > > > > >
> > > > > >
> > > > > > On Thu, Jan 10, 2019 at 9:59 PM Yuriy Babak <[hidden email]>
> > > wrote:
> > > > > >
> > > > > > > Hi Igniters,
> > > > > > >
> > > > > > > What do you think about the drop Scala 2.10 support?
> > > > > > >
> > > > > > > Currently, we support two versions of Scala - 2.10 and 2.11, I
> > > > suggest
> > > > > to
> > > > > > > drop 2.10 and use only 2.11. Originally we have the old version
> > of
> > > > > Scala
> > > > > > > for supporting old versions of Apache Spark.
> > > > > > >
> > > > > > > But support for Scala 2.10 was removed as of 2.3.0 Apache Spark
> > > > > released.
> > > > > > > And current version if 2.4.0.
> > > > > > >
> > > > > > > Please share your opinion
> > > > > > >
> > > > > > > Best regards,
> > > > > > > Yuriy Babak
> > > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Alexey Kuznetsov
> > > > > >
> > > > >
> > > >
> > >
> >
>