Options naming format in control.sh utility.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Options naming format in control.sh utility.

antonovsergey93
Hi, Igniters!

I want discuss and define options naming format in our utilities. I found
two naming styles in CommandHandler class  --excludeCaches and --skip-zeros.
I think we should unify it. At this moment almost all options have second
naming format. I am offering rename --excludeCaches to --exclude-caches and
define format for future options. How about linux like format i.e.
--word1-word2?

--
BR, Sergey Antonov
Reply | Threaded
Open this post in threaded view
|

Re: Options naming format in control.sh utility.

Sergey Kozlov
Sergey,

Thanks for raising up the question.

Did you mean following (?):
 - boolean argument: *--word1-word2*
 - single value argument  *--word1-word2=value*
 - multiple values argument  *--word1-word2=value1  --word1-word2=value2*


On Fri, Jan 11, 2019 at 2:05 PM Sergey Antonov <[hidden email]>
wrote:

> Hi, Igniters!
>
> I want discuss and define options naming format in our utilities. I found
> two naming styles in CommandHandler class  --excludeCaches and
> --skip-zeros.
> I think we should unify it. At this moment almost all options have second
> naming format. I am offering rename --excludeCaches to --exclude-caches and
> define format for future options. How about linux like format i.e.
> --word1-word2?
>
> --
> BR, Sergey Antonov
>


--
Sergey Kozlov
GridGain Systems
www.gridgain.com
Reply | Threaded
Open this post in threaded view
|

Re: Options naming format in control.sh utility.

antonovsergey93
Sergey,

Not quite, I meant:
- boolean argument: *--word1-word2*
- single value argument  *--word1-word2 value*
- multiple values argument  *--word1-word2 value1,value2*

пт, 11 янв. 2019 г. в 14:12, Sergey Kozlov <[hidden email]>:

> Sergey,
>
> Thanks for raising up the question.
>
> Did you mean following (?):
>  - boolean argument: *--word1-word2*
>  - single value argument  *--word1-word2=value*
>  - multiple values argument  *--word1-word2=value1  --word1-word2=value2*
>
>
> On Fri, Jan 11, 2019 at 2:05 PM Sergey Antonov <[hidden email]>
> wrote:
>
> > Hi, Igniters!
> >
> > I want discuss and define options naming format in our utilities. I found
> > two naming styles in CommandHandler class  --excludeCaches and
> > --skip-zeros.
> > I think we should unify it. At this moment almost all options have second
> > naming format. I am offering rename --excludeCaches to --exclude-caches
> and
> > define format for future options. How about linux like format i.e.
> > --word1-word2?
> >
> > --
> > BR, Sergey Antonov
> >
>
>
> --
> Sergey Kozlov
> GridGain Systems
> www.gridgain.com
>


--
BR, Sergey Antonov