[jira] [Created] (IGNITE-8987) Ignite hangs during getting of atomic structure after autoactivation

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (IGNITE-8987) Ignite hangs during getting of atomic structure after autoactivation

JIRA jira@apache.org
Andrey Aleksandrov created IGNITE-8987:
------------------------------------------

             Summary: Ignite hangs during getting of atomic structure after autoactivation
                 Key: IGNITE-8987
                 URL: https://issues.apache.org/jira/browse/IGNITE-8987
             Project: Ignite
          Issue Type: Bug
          Components: cache
    Affects Versions: 2.4
            Reporter: Andrey Aleksandrov
             Fix For: 2.7
         Attachments: reproducer.java

I investigate the use cases with autoactivation and creating of the IgniteAtomicSequence. It hangs on awaitInitialization() method in case if it called after the last node from BLT was started.

Steps to reproduce:

First iteration:
 
Do next in one thread:

1)Start server 1
2)Start server 2
3)Activate the cluster 
4)Create the IgniteAtomicSequence using next code:


IgniteAtomicSequence igniteAtomicSequence = ignite.atomicSequence(
 "TestName",
 atomicConfiguration,
 10,
 true);

Second iteration:

1)Start server 1
2)Start server 2 (Autoactivation will be started)
3)Get the IgniteAtomicSequence using next code:


IgniteAtomicSequence igniteAtomicSequence = ignite.atomicSequence(
 "TestName",
 10,
 true); //could be false because TestName was already created in iteration 1

In this case, we hang in awaitInitialization() method in DataStructureProcessor.getAtomic() method.

In case if I added some sleep timeout between step 2 and 3 in the second iteration then everything was ok. Looks like we have some race here.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)